Technical FAQs

Ask a Question

What is the minimum operating system requirement for Ecodial installation.

The minimum operating system requirement for Ecodial are :
- Windows XP Professional SP2 or SP3
- Windows Vista 32 bit
- Windows Seven (32 & 64 bit).
- Up to date graphic drivers.
 
Was this helpful?
What can we do to improve the information ?